Performance Issues - Resolved

Minor incident Conceptboard Web Application
2026-03-05 17:13 CET · 17 hours, 46 minutes

Updates

Update

We have fixed the performance issues and limitations of 5 March and introduced several additional internal alarms to be able to respond quicker to such events in the future.
Thank you for your patience and again we are sorry for the inconveniences caused.

March 6, 2026 · 09:51 CET
Update

Our team has initiated a rollback. The services already look healthier and performance has been largely improved since.

We will keep the incident open for the moment and be closely monitoring performance tomorrow as well to be able to react to any new developments swiftly.

March 5, 2026 · 20:21 CET
Issue

We are currently investigating possible service interruptions.

Our team is actively investigating the incident and will update you with more details as soon as possible.

We kindly ask for your understanding.

March 5, 2026 · 09:00 CET

← Back