Problems Uploading Media to Boards - Investigating

Minor incident Conceptboard Web Application
2025-11-27 12:00 CET · 5 hours, 10 minutes

Updates

Resolved

The issue is resolved

November 27, 2025 · 16:00 CET
Issue

We have received reports users are unable to uploads images and other media to boards are receiving error messages.

Our team is actively investigating the incident and will update you with more details as soon as possible.

We kindly ask for your understanding.

November 27, 2025 · 13:37 CET

← Back