Hotfix release

Major incident Conceptboard Web Application
2025-11-04 06:13 CET · 6 minutes

Updates

Resolved

Service is back up.

We have addressed issues regarding the wrongful display of board object limits on some professional boards.

We are aware of persisting issues with the conferencing tool and working on a resolution as fast as possible.

November 4, 2025 · 06:19 CET
Issue

We apologize for the inconvenience when trying to reach our services.

Our team is working on a hotfix deployment.

November 4, 2025 · 06:13 CET

← Back