Minor Incident - Resolved
Minor incident
Conceptboard Web Application
2025-09-30 15:00 CEST
· 23 hours, 25 minutes
Updates
Resolved
October 1, 2025 · 14:00 CEST
The performance issues have been resolved, thank you for your patience.
Update
October 1, 2025 · 10:55 CEST
The known issues regarding image upload and general board loading times have been resolved.
Some users may still experience longer loading times when exporting - our team is working on a resolution as fast as possible.
Issue
October 1, 2025 · 09:44 CEST
We are aware of issues regarding board loading, upload and export that affect some users at the moment.
Our team is actively investigating the incident and working on a resolution.
We kindly ask for your understanding.
← Back