Minor Incident - Resolved

Minor incident Conceptboard Web Application
2025-06-10 15:30 CEST · 19 hours, 45 minutes

Updates

Resolved

The performance issues have been resolved, thank you for your patience.

June 11, 2025 · 10:00 CEST
Issue

We are aware of temporary performance limitations with the app regarding board loading times for some users.

Our team is actively investigating the incident and will update you with more details as soon as possible.

We kindly ask for your understanding.

June 10, 2025 · 15:30 CEST

← Back