Minor Incident - Resolved

Minor incident Conceptboard Web Application
2025-04-09 11:00 CEST · 1 day

Updates

Investigating

We are currently investigating possible service interruptions beginning 9th of April.

Our team is actively investigating the incident and will update you with more details as soon as possible.

We kindly ask for your understanding.

April 10, 2025 · 14:11 CEST
Update

The issues have been resolved, thank you for your patience.

April 10, 2025 · 11:00 CEST

← Back