Major Incident - Resolved

Major incident Conceptboard Web Application
2024-11-11 17:16 CET · 4 minutes

Updates

Resolved

The issue has been resolved, our services are now back to normal again, thank you for your patience

November 11, 2024 · 17:21 CET
Issue

We are currently investigating possible service interruptions.

Our team is actively investigating the incident and will update you with more details as soon as possible.

We kindly ask for your understanding.

November 11, 2024 · 17:16 CET

← Back