Minor Incident - Resolved

Minor incident Conceptboard Web Application
2024-10-08 14:15 CEST · 2 hours, 15 minutes

Updates

Update

The standard board loading times have been restored, thank you for your patience.

October 8, 2024 · 16:30 CEST
Issue

At the moment, there may be temporary performance limitations with the app regarding board loading times.

Our team is actively investigating the incident and will update you with more details as soon as possible.

We kindly ask for your understanding.

October 8, 2024 · 14:15 CEST

← Back