Major Incident - Resolved
Major incident
Conceptboard Web Application
2024-09-16 15:50 CEST
· 2 minutes
Updates
Resolved
September 16, 2024 · 15:52 CEST
We apologize for the inconvenience when trying to reach our services.
Our team is working on a resolution as fast as possible.
Issue
September 16, 2024 · 15:50 CEST
We are currently investigating possible service interruptions.
Our team is actively investigating the incident and will update you with more details as soon as possible.
We kindly ask for your understanding.
← Back