Major Incident - Resolved

Major incident Conceptboard Web Application
2024-09-16 15:03 CEST · 2 minutes

Updates

Resolved

Our team is working on a resolution as fast as possible.

September 16, 2024 · 15:06 CEST
Issue

We are currently investigating possible service interruptions.

Our team is actively investigating the incident and will update you with more details as soon as possible.

We kindly ask for your understanding.

September 16, 2024 · 15:03 CEST

← Back