Minor Incident - Resolved

Minor incident Conceptboard Web Application
2024-07-07 09:01 CEST · 1 hour, 15 minutes

Updates

Resolved

The performance issues have been largely resolved, thank you for your patience.

July 7, 2024 · 10:17 CEST
Issue

The performance issues have been resolved, thank you for your patience.

July 7, 2024 · 09:01 CEST

← Back