Minor Incident - Monitoring

Minor incident Conceptboard Web Application
2024-03-27 10:19 CEST · 9 minutes

Updates

Resolved

Service is back up.

March 27, 2024 · 10:29 CEST
Issue

At the moment, there may be temporary performance limitations with the app due to the current circumstances.

We kindly ask for your understanding.

March 27, 2024 · 10:19 CEST

← Back